Linux als VM der Generation 2

openSUSE 13.1 x64 ist die einzige Linux Distribution, bei der mir eine Installation unter Hyper-V als virtuelle Maschine der „Generation 2“ gelungen ist. Zuerst bekam ich die Meldung „Boot Failed. EFI SCSI Device. Failed Secure Boot Verification.“ Der Workaround ist, Secure Boot auszuschalten.

UEFI Secure Boot ausschalten
UEFI Secure Boot einer VM der Generation 2 ausschalten

Im Dialog vor dem eigentlichen Setup funktioniert die Tastatur nicht. Daher kann man dort keinen non-root-User anlegen und kein Passwort für root festlegen. Wenn man weiter installiert, wird man nach dem Setup noch mal nach einem Root-Passwort gefragt und dann geht die Tastatur auch wieder. Das dürfte daran liegen, dass in der „Generation 2“ der Tastaturcontroller i8042 nicht emuliert wird.

Nachtrag 22.11.2014: openSUSE 13.2 zeigt das Tastaturproblem nicht mehr und kann problemlos als VM der Generation 2 installiert werden, wenn man Secure Boot ausschaltet.